using ssl::context in boost 1.53 versions

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

using ssl::context in boost 1.53 versions

Boost - Users mailing list
Hi , 

I am currently using boost 1.53 version. cannot upgrade to latest version.

Using ssl asio.

Here is my requirement.

I need to support tls1.1.and tls1.2 protocol in the server, but not tls1.0  . 
As there are no options for tls1.1. and tls1.2 ,and context is not present with relevant tls1.1 and tls1.2 versions,

I created the ssl::context with tlsv1 method and used 

long ssl_disallowed = SSL_OP_NO_SSLv2 | SSL_OP_NO_SSLv3 | SSL_OP_NO_TLSv1 | SSL_OP_NO_TLSv1_1 | SSL_OP_NO_TLSv1_2;
       ssl_disallowed &= ~SSL_OP_NO_TLSv1_2;
       ssl_disallowed &= ~SSL_OP_NO_TLSv1_1;

       SSL_CTX_set_options(myBoostSslcontext.native_handle(), ssl_disallowed|SSL_OP_SINGLE_DH_USE);
 

But handshake seems to be failing for any other versions other than tlsv1.

Can you please let me know how to I set the options so that my  sserver can accept tls connections on tls1.1 and tls1.2 with boost version 1.53.

Thanks in advance.
Dipti

_______________________________________________
Boost-users mailing list
[hidden email]
https://lists.boost.org/mailman/listinfo.cgi/boost-users
Loading...