unable to update boost version

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

unable to update boost version

Boost - Users mailing list
Respected Sir/Madam,
 I am running a code where the minimum required version of the boost package is 66. But the version of boost in my laptop is 65.  I tried the command
sudo apt install  libboost-filesystem-dev libboost-log-dev
But it failed to update. Then I tried to download the package from the website and followed the instructions to install it. But still the version is still 65. 

Could you kindly help me, please?

Thanking you,

Sincerely,
Shiladitya Porey

--
Shiladitya Porey
Office: Room no. : 434,Old Building
Mobile: 8 913 462-44-32

_______________________________________________
Boost-users mailing list
[hidden email]
https://lists.boost.org/mailman/listinfo.cgi/boost-users
Reply | Threaded
Open this post in threaded view
|

Re: unable to update boost version

Boost - Users mailing list
You will need to download boost and build from source into a custom directory.

Downloads here:

Then bootstrap and build:

$ ./bootstrap.sh 
$ ./b2 —prefix=<destination-dir> variant=release install



On Thu, 24 Sep 2020 at 08:05, Shiladitya Porey via Boost-users <[hidden email]> wrote:
Respected Sir/Madam,
 I am running a code where the minimum required version of the boost package is 66. But the version of boost in my laptop is 65.  I tried the command
sudo apt install  libboost-filesystem-dev libboost-log-dev
But it failed to update. Then I tried to download the package from the website and followed the instructions to install it. But still the version is still 65. 

Could you kindly help me, please?

Thanking you,

Sincerely,
Shiladitya Porey

--
Shiladitya Porey
Office: Room no. : 434,Old Building
Mobile: 8 913 462-44-32


_______________________________________________

Boost-users mailing list

[hidden email]

https://lists.boost.org/mailman/listinfo.cgi/boost-users

--
Richard Hodges
office: +442032898513
home: +376841522
mobile: +376380212


_______________________________________________
Boost-users mailing list
[hidden email]
https://lists.boost.org/mailman/listinfo.cgi/boost-users
Reply | Threaded
Open this post in threaded view
|

Re: unable to update boost version

Boost - Users mailing list
In reply to this post by Boost - Users mailing list
On 24/09/2020 17:37, Shiladitya Porey wrote:
>   I am running a code where the minimum required version of the boost
> package is 66. But the version of boost in my laptop is 65.  I tried the
> command
>
>     sudo apt install  libboost-filesystem-dev libboost-log-dev
>
> But it failed to update. Then I tried to download the package from the
> website and followed the instructions to install it. But still the
> version is still 65.

If you are using an older version of Linux, it may come with an older
version of Boost as well.

Either you will need to download and build a later version manually (and
ensure that your other code is pointed at this installation instead of
the standard system one), or you can try upgrading your OS to a newer
version that includes a newer version of Boost as well.
_______________________________________________
Boost-users mailing list
[hidden email]
https://lists.boost.org/mailman/listinfo.cgi/boost-users