"Archive has no index" when linking to newly built boost 1.69

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

"Archive has no index" when linking to newly built boost 1.69

Boost - Build mailing list
Cross compiled for QNX 7 on Ubuntu by:
bootsrap.sh --with-icu
then
 ./b2 toolset=qcc target-os=qnxnto threadapi=pthread link=static -l240 --layout=system --without-python cxxflags="-Vgcc_ntox86_64 -Y_gpp" linkflags="-Vgcc_ntox86_64 -Y_gpp -lang-c++" -j7 > buildlog.txt 2>&1


The build looked very good, couldn't detect anything wrong.  But when I try to build the sample regex app:
#include <iostream>
#include <boost/regex.hpp>

int main() {


    std::string line;
    boost::regex pat( "^Subject: (Re: |Aw: )*(.*)" );

    while (std::cin)
    {
        std::getline(std::cin, line);
        boost::smatch matches;
        if (boost::regex_match(line, matches, pat))
            std::cout << matches[2] << std::endl;
    }
    return 0;
}
-----------------------------------
make -j8 all
qcc -lang-c++ -Vgcc_ntox86 -c -Wp,-MMD,build/x86-debug/src/t2.d,-MT,build/x86-debug/src/t2.o -o build/x86-debug/src/t2.o  -Wall -fmessage-length=0 -g -O0 -fno-builtin  src/t2.cpp
qcc -lang-c++ -Vgcc_ntox86 -o build/x86-debug/t2  -LC:/qnx700/target/qnx7/usr/pkg/lib/boost_1_69_x86_64 build/x86-debug/src/t2.o  -lboost_regex
C:/qnx700/target/qnx7/usr/pkg/lib/boost_1_69_x86_64\libboost_regex.a: error adding symbols: Archive has no index; run ranlib to add one
cc: C:/qnx700/host/win64/x86_64/usr/bin/i586-pc-nto-qnx7.0.0-ld caught signal 1


Any thoughts??  Thanks in advance.
Ian

_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build
Reply | Threaded
Open this post in threaded view
|

"Archive has no index" When Linking to Newly Built Boost 1.69

Boost - Build mailing list
Sorry for the repeat but the formatting on my original got garbled somehow.

 Cross compiled for QNX 7 on Ubuntu by:
 
 bootsrap.sh --with-icu  

 ./b2 toolset=qcc target-os=qnxnto threadapi=pthread link=static -l240 --layout=system --without-python cxxflags="-Vgcc_ntox86_64 -Y_gpp" linkflags="-Vgcc_ntox86_64 -Y_gpp -lang-c++" -j7 > buildlog.txt 2>&1

The build looked very good, couldn't detect anything wrong.   But when I try to build the sample regex app:

#include <iostream>
#include <boost/regex.hpp>

int main() {

       std::string line;
       boost::regex pat( "^Subject: (Re: |Aw: )*(.*)" );

       while (std::cin)
       {
               std::getline(std::cin, line);
               boost::smatch matches;
               if (boost::regex_match(line, matches, pat))
                       std::cout << matches[2] << std::endl;
       }
       return 0;
}
-----------------------------------
make -j8 all
qcc -lang-c++ -Vgcc_ntox86 -c -Wp,-MMD,build/x86-debug/src/t2.d,-MT,build/x86-debug/src/t2.o -o build/x86-debug/src/t2.o   -Wall -fmessage-length=0 -g -O0 -fno-builtin   src/t2.cpp
qcc -lang-c++ -Vgcc_ntox86 -o build/x86-debug/t2   -LC:/qnx700/target/qnx7/usr/pkg/lib/boost_1_69_x86_64 build/x86-debug/src/t2.o   -lboost_regex

C:/qnx700/target/qnx7/usr/pkg/lib/boost_1_69_x86_64\libboost_regex.a: error adding symbols: Archive has no index; run ranlib to add one
cc: C:/qnx700/host/win64/x86_64/usr/bin/i586-pc-nto-qnx7.0.0-ld caught signal 1


Any thoughts??   
Thanks in advance.
Ian



_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build