[program_options] cmake discovery issue

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[program_options] cmake discovery issue

Boost - Users mailing list
Hello,
I can't say when these errors first appeared, certainly not in Boost 1.63 . I
have a project working with cmake and the following cmmake lines:
set(Boost_USE_MULTITHREADED ON)
find_package(Boost 1.58 REQUIRED COMPONENTS program_options filesystem
date_time system)
if (Boost_PROGRAM_OPTIONS_FOUND)
   set (INCS ${INCS} ${Boost_INCLUDE_DIRS})
   set (LIBS ${LIBS} ${Boost_PROGRAM_OPTIONS_LIBRARY} ${Boost_SYSTEM_LIBRARY})
endif (Boost_PROGRAM_OPTIONS_FOUND)

Which says that it found the libraries and lower down produces this error:
CMake Error in CMakeLists.txt:
   Imported target "Boost::program_options" includes non-existent path
   "/include"
   in its INTERFACE_INCLUDE_DIRECTORIES.  Possible reasons include:
   * The path was deleted, renamed, or moved to another location.
   * An install or uninstall procedure did not complete successfully.
   * The installation package was faulty and references files it does not provide.
This error appears twice in the output.

My cmake skills are too meagre to trace it to a particular point in the Boost
Cmake modules.

Could someone please help? Is it perhaps my fault for not updating a call
somewhere?

Best wishes and TIA,

Jeanette

--
  * Website: http://juliencoder.de - for summer is a state of sound
  * Youtube: https://www.youtube.com/channel/UCMS4rfGrTwz8W7jhC1Jnv7g
  * SoundCloud: https://soundcloud.com/jeanette_c
  * Twitter: https://twitter.com/jeanette_c_s
  * Audiobombs: https://www.audiobombs.com/users/jeanette_c
  * GitHub: https://github.com/jeanette-c

There's no time to loose
And next week,
You might not see me here <3
(Britney Spears)
_______________________________________________
Boost-users mailing list
[hidden email]
https://lists.boost.org/mailman/listinfo.cgi/boost-users