pd darwin Symbol not found

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

pd darwin Symbol not found

Locatelli Jérôme

        I'am writing a application on MacOS 10.4.4 using darwin 8 with gcc 4,  
I compile and link my application without problem but when I run my  
application , I've got the error bellow. Has anybody got an idear??

        Thanks.


dyld: lazy symbol binding failed: Symbol not found:  
__ZN5boost6detail3tss4initEPNS_9function1IvPvSaINS_13function_baseEEEE
   Referenced from:  
/Users/locatelli/Projets/ics/IcsServer/obj.ics/../lib/
libIcsServerCommandSystem.0
   Expected in: flat namespace

dyld: Symbol not found:  
__ZN5boost6detail3tss4initEPNS_9function1IvPvSaINS_13function_baseEEEE
   Referenced from:  
/Users/locatelli/Projets/ics/IcsServer/obj.ics/../lib/
libIcsServerCommandSystem.0
   Expected in: flat namespace

Trace/BPT trap

---------------------------------------------------
Locatelli Jérôme
Institut Laue-Langevin
Service Contrôle des instruments
6 rue Jules Horowitz, BP 156
38042 Grenoble cedex 9
http://www.ill.fr/
Tel: 33 (0)4 76 20 76 27
Fax: 33 (0)4 76 20 77 00
---------------------------------------------------
_______________________________________________
Boost-users mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-users
Reply | Threaded
Open this post in threaded view
|

Re: pd darwin Symbol not found

RIVASSEAU Jean Noel

Do you develop in XCode ? I remember that while developing on XCode there is an option that does fast linking (it is called Zero Link) and if you check that, it does not really link your application at link time but only at run time.

 

So I think this is in fact a linking problem, disable the Zero Link option under XCode and your code will probably fail to link.

 

As to why it does not link, I do not know, which library (boost) are you trying to link to ?

 

Jean-Noël

 

 

 


De : [hidden email] [mailto:[hidden email]] De la part de Locatelli Jérôme
Envoyé : jeudi 9 février 2006 14:14
À : [hidden email]
Objet : [Boost-users] pd darwin Symbol not found

 

I'am writing a application on MacOS 10.4.4 using darwin 8 with gcc 4, I compile and link my application without problem but when I run my application , I've got the error bellow. Has anybody got an idear??

 

Thanks.

 

dyld: lazy symbol binding failed: Symbol not found: __ZN5boost6detail3tss4initEPNS_9function1IvPvSaINS_13function_baseEEEE

Referenced from: /Users/locatelli/Projets/ics/IcsServer/obj.ics/../lib/libIcsServerCommandSystem.0

Expected in: flat namespace

 

dyld: Symbol not found: __ZN5boost6detail3tss4initEPNS_9function1IvPvSaINS_13function_baseEEEE

Referenced from: /Users/locatelli/Projets/ics/IcsServer/obj.ics/../lib/libIcsServerCommandSystem.0

Expected in: flat namespace

 

Trace/BPT trap

 

---------------------------------------------------

Locatelli Jérôme

Institut Laue-Langevin

Service Contrôle des instruments

6 rue Jules Horowitz, BP 156

38042 Grenoble cedex 9

http://www.ill.fr/

Tel: 33 (0)4 76 20 76 27

Fax: 33 (0)4 76 20 77 00

---------------------------------------------------


_______________________________________________
Boost-users mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-users
Reply | Threaded
Open this post in threaded view
|

Re: pd darwin Symbol not found

Locatelli Jérôme
I don't use xcode to compile. We use a GNU makefile. I try to link  
those library : boost_thread and boost_regex.


Le 9 févr. 06, à 16:55, RIVASSEAU Jean Noel a écrit :

>
> Do you develop in XCode ? I remember that while developing on XCode  
> there is an option that does fast linking (it is called Zero Link) and  
> if you check that, it does not really link your application at link  
> time but only at run time.
>  
> So I think this is in fact a linking problem, disable the Zero Link  
> option under XCode and your code will probably fail to link.
>  
> As to why it does not link, I do not know, which library (boost) are  
> you trying to link to ?
>  
> Jean-Noël
>  
>  
>  
>
> De : [hidden email]  
> [mailto:[hidden email]] De la part de Locatelli  
> Jérôme
> Envoyé : jeudi 9 février 2006 14:14
> À : [hidden email]
> Objet : [Boost-users] pd darwin Symbol not found
>  
> I'am writing a application on MacOS 10.4.4 using darwin 8 with gcc 4,  
> I compile and link my application without problem but when I run my  
> application , I've got the error bellow. Has anybody got an idear??
>  
> Thanks.
>
>  
> dyld: lazy symbol binding failed: Symbol not found:  
> __ZN5boost6detail3tss4initEPNS_9function1IvPvSaINS_13function_baseEEEE
> Referenced from:  
> /Users/locatelli/Projets/ics/IcsServer/obj.ics/../lib/
> libIcsServerCommandSystem.0
> Expected in: flat namespace
>  
> dyld: Symbol not found:  
> __ZN5boost6detail3tss4initEPNS_9function1IvPvSaINS_13function_baseEEEE
> Referenced from:  
> /Users/locatelli/Projets/ics/IcsServer/obj.ics/../lib/
> libIcsServerCommandSystem.0
> Expected in: flat namespace
>  
> Trace/BPT trap
>  
> ---------------------------------------------------
> Locatelli Jérôme
> Institut Laue-Langevin
> Service Contrôle des instruments
> 6 rue Jules Horowitz, BP 156
> 38042 Grenoble cedex 9
> http://www.ill.fr/
> Tel: 33 (0)4 76 20 76 27
> Fax: 33 (0)4 76 20 77 00
> ---------------------------------------------------
> _______________________________________________
> Boost-users mailing list
> [hidden email]
> http://lists.boost.org/mailman/listinfo.cgi/boost-users
---------------------------------------------------
Locatelli Jérôme
Institut Laue-Langevin
Service Contrôle des instruments
6 rue Jules Horowitz, BP 156
38042 Grenoble cedex 9
http://www.ill.fr/
Tel: 33 (0)4 76 20 76 27
Fax: 33 (0)4 76 20 77 00
---------------------------------------------------

_______________________________________________
Boost-users mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-users
Reply | Threaded
Open this post in threaded view
|

Re: pd darwin Symbol not found

Rush Manbert
Locatelli Jérôme wrote:
> I don't use xcode to compile. We use a GNU makefile. I try to link those
> library : boost_thread and boost_regex.
>
>
> Le 9 févr. 06, à 16:55, RIVASSEAU Jean Noel a écrit :
>
>
>     Do you develop in XCode ? I remember that while developing on XCode

<snip>

>     Locatelli Jérôme
>     *Envoyé :* jeudi 9 février 2006 14:14
>     *À :* [hidden email]
>     *Objet :* [Boost-users] pd darwin Symbol not found
>      
>     I'am writing a application on MacOS 10.4.4 using darwin 8 with gcc
>     4, I compile and link my application without problem but when I run
>     my application , I've got the error bellow. Has anybody got an idear??
>      
>     Thanks.
>
>      
>     dyld: lazy symbol binding failed: Symbol not found:
>     __ZN5boost6detail3tss4initEPNS_9function1IvPvSaINS_13function_baseEEEE
>     Referenced from:
>     /Users/locatelli/Projets/ics/IcsServer/obj.ics/../lib/libIcsServerCommandSystem.0
>
>     Expected in: flat namespace
>      
>     dyld: Symbol not found:
>     __ZN5boost6detail3tss4initEPNS_9function1IvPvSaINS_13function_baseEEEE
>     Referenced from:
>     /Users/locatelli/Projets/ics/IcsServer/obj.ics/../lib/libIcsServerCommandSystem.0
>
>     Expected in: flat namespace
>      
>     Trace/BPT trap

I would try linking against the static libraries, and see whether you
get errors in that case. (Thinking that link time errors might be easier
to decode than runtime link errors.) On the Mac, this is probably
easiest if you uniquely name the static libs and change your -l params
to the linker. If the dylib and the static lib are both in the linker
search paths and their names only differ by extension, then the linker
will prefer the dylib, so the rename is the easiest workaround for
testing. (Or maybe change the dylib names to something that won't get
found and leave the linker commands alone. That's a smaller perturbation.)

- Rush
_______________________________________________
Boost-users mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-users