*newbie* 'BOOST_INTRUSIVE_HAS_MEMBER_FUNCTION_CALLABLE_WITH_ITERATION' : undeclared identifier

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

*newbie* 'BOOST_INTRUSIVE_HAS_MEMBER_FUNCTION_CALLABLE_WITH_ITERATION' : undeclared identifier

Greg Werner
Hi all new to the list.

When trying to build a rather large project which uses boost, I get the following few lines 12 times during the build process:

7>c:\local\boost_1_60_0\boost\intrusive\detail\has_member_function_callable_with.hpp(303): error C2065: 'BOOST_INTRUSIVE_HAS_MEMBER_FUNCTION_CALLABLE_WITH_ITERATION' : undeclared identifier
7>c:\local\boost_1_60_0\boost\intrusive\detail\has_member_function_callable_with.hpp(320): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
7>c:\local\boost_1_60_0\boost\intrusive\detail\has_member_function_callable_with.hpp(320): error C2143: syntax error : missing ';' before ''template<''

Others can build this same project just fine and I can't find anything on the internet which would indicate others having problems with this file.  I am using VS2010 Professional Version with SP1.  My compiler and boost libraries are both 32 bit.  I tried uninstalling and reinstalling everything but same errors.  These are the only errors which prevent my project from successful build.

Any ideas as to what could cause this?

-Greg

_______________________________________________
Boost-users mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-users
Reply | Threaded
Open this post in threaded view
|

Re: *newbie* 'BOOST_INTRUSIVE_HAS_MEMBER_FUNCTION_CALLABLE_WITH_ITERATION' : undeclared identifier

Greg Werner
Let me just say I figured it out.  

Boost 1.56 works well with our solution, but Boost 1.60 is not compatible.  The existing VS project files used a mixture of references to 1.56 and 1.60 so it looked like 1.60 was working when in fact it was not.