libs build errors "64 bit mode not compiled in"

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

libs build errors "64 bit mode not compiled in"

Boost - Build mailing list
Hello,

I want to build the boost libs on my system (os: Windows 10 Pro 32 bit). My build command is:
b2 -j2 --build-dir=D:\boost_1_67_0\boost_1_67_0\Build toolset=gcc variant=debug link=static --build-type=complete stage
But the problem is: I get errors like "sorry, unimplemented: 64 bit mode not compiled in" as you see for example in this screenshot: http://pasteall.org/pic/a5b5c04a30f834f5492fd5ac004f99f0
Any ideas? Thanks!

_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build
Reply | Threaded
Open this post in threaded view
|

Re: libs build errors "64 bit mode not compiled in"

Boost - Build mailing list
AMDG

On 05/23/2018 07:25 AM, Benjamin Müller via Boost-build wrote:

>
> I want to build the boost libs on my system (os: Windows 10 Pro 32 bit).
> My build command is:
> b2 -j2 --build-dir=D:\boost_1_67_0\boost_1_67_0\Build toolset=gcc
> variant=debug link=static --build-type=complete stage
> But the problem is: I get errors like "sorry, unimplemented: 64 bit mode
> not compiled in" as you see for example in this screenshot:
> http://pasteall.org/pic/a5b5c04a30f834f5492fd5ac004f99f0
> Any ideas? Thanks!
>

  Use address-model=32 or get a compiler that supports
64-bit compilation.  --build-type=complete tries to
build both 32 and 64-bit versions of the libraries
on Windows.

In Christ,
Steven Watanabe
_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build
Reply | Threaded
Open this post in threaded view
|

Re: libs build errors "64 bit mode not compiled in"

Boost - Build mailing list
Hello,
I used the option you gave me, and further I built only the libraries I
really need (thread, atomic, container). My build command looks like
this now:
b2 -j2 --build-dir=D:\boost_1_67_0\boost_1_67_0\Build --address-model=32
--with-atomic --with-container --with-thread toolset=gcc variant=debug
link=static threading=multi stage
But the errors still appear like here:
http://pasteall.org/pic/5335cb9da52dbe86701a87c45fb99f97
Any ideas? Thanks!

------ Originalnachricht ------
Von: "Steven Watanabe via Boost-build" <[hidden email]>
An: "Benjamin Müller via Boost-build" <[hidden email]>
Cc: "Steven Watanabe" <[hidden email]>
Gesendet: 23.05.2018 15:33:12
Betreff: Re: [Boost-build] libs build errors "64 bit mode not compiled
in"

>AMDG
>
>On 05/23/2018 07:25 AM, Benjamin Müller via Boost-build wrote:
>>
>>  I want to build the boost libs on my system (os: Windows 10 Pro 32
>>bit).
>>  My build command is:
>>  b2 -j2 --build-dir=D:\boost_1_67_0\boost_1_67_0\Build toolset=gcc
>>  variant=debug link=static --build-type=complete stage
>>  But the problem is: I get errors like "sorry, unimplemented: 64 bit
>>mode
>>  not compiled in" as you see for example in this screenshot:
>>  http://pasteall.org/pic/a5b5c04a30f834f5492fd5ac004f99f0
>>  Any ideas? Thanks!
>>
>
>   Use address-model=32 or get a compiler that supports
>64-bit compilation.  --build-type=complete tries to
>build both 32 and 64-bit versions of the libraries
>on Windows.
>
>In Christ,
>Steven Watanabe
>_______________________________________________
>Unsubscribe & other changes:
>https://lists.boost.org/mailman/listinfo.cgi/boost-build

_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build
Reply | Threaded
Open this post in threaded view
|

Re: libs build errors "64 bit mode not compiled in"

Boost - Build mailing list
On 25 May 2018 at 12:10, Benjamin Müller via Boost-build
<[hidden email]> wrote:
> Hello,
> I used the option you gave me, and further I built only the libraries I
> really need (thread, atomic, container). My build command looks like this
> now:
> b2 -j2 --build-dir=D:\boost_1_67_0\boost_1_67_0\Build --address-model=32

Shouldn't
--address-model=32
read
address-model=32
?

AFAIU, address-model is a build feature as toolset, variant, etc.

Best regards,
--
Mateusz Loskot, http://mateusz.loskot.net
_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build
Reply | Threaded
Open this post in threaded view
|

Re: libs build errors "64 bit mode not compiled in"

Boost - Build mailing list
On 5/25/2018 5:14 AM, Mateusz Loskot via Boost-build wrote:

> On 25 May 2018 at 12:10, Benjamin Müller via Boost-build
> <[hidden email]> wrote:
>> Hello,
>> I used the option you gave me, and further I built only the libraries I
>> really need (thread, atomic, container). My build command looks like this
>> now:
>> b2 -j2 --build-dir=D:\boost_1_67_0\boost_1_67_0\Build --address-model=32
>
> Shouldn't
> --address-model=32
> read
> address-model=32
> ?
>
That is the correct way to set the address-model.  A 64-bit truncated
example using the path above:

b2 --build-dir="D:\boost_1_67_0\boost_1_67_0\Build"
--libdir="D:\boost_1_67_0\boost_1_67_0\Build\lib" architecture=x86
address-model=64 toolset="msvc-14.1" --with-test

--Robert

> AFAIU, address-model is a build feature as toolset, variant, etc.
>
> Best regards,
>

_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build