[hash] hash_float_test failure

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[hash] hash_float_test failure

Vladimir Prus

Hello!

The functional/hash/has_float_test test fails in CalebEpstein-V2 test results.

I suspect that's some Sun-specific floating point accuracy issue.

Caleb, can you check if that test works with V1? If so, can you get command
lines for both V1 and V2 via:

  1. Going to libs/functional/hast/test
  2. Running "bjam -a -n -sTOOLS=gcc-3-4-3" and then
      "bjam -n -a --v2 gcc-3.4.3"

and then send the command lines to me.

If the test fails with V1, then maybe we need some Sun expert to tell the
right command line option.

Thanks,
Volodya
_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: [hash] hash_float_test failure

Caleb Epstein-3
On 3/13/06, Vladimir Prus <[hidden email]> wrote:
>
> The functional/hash/has_float_test test fails in CalebEpstein-V2 test
> results.
>
> I suspect that's some Sun-specific floating point accuracy issue.
>
> Caleb, can you check if that test works with V1? If so, can you get
> command


They don't and never have.  There is markup in
explicit-failures-markup.xmlfor this failure (and similar ones in
math/octonion_test and
quaternion_test), but the toolset name was BBv1-style.  I'v corrected this
in CVS.

--
Caleb Epstein
caleb dot epstein at gmail dot com
_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: [hash] hash_float_test failure

Daniel James
In reply to this post by Vladimir Prus
On 3/13/06, Vladimir Prus <[hidden email]> wrote:
>
> The functional/hash/has_float_test test fails in CalebEpstein-V2 test results.
>
> I suspect that's some Sun-specific floating point accuracy issue.
>
> Caleb, can you check if that test works with V1? If so, can you get command
> lines for both V1 and V2 via:

The test has been failing for some time. This failure suggests a
problem with ldexp or frexp for long doubles. Looking at
http://lists.boost.org/Archives/boost/2005/04/83872.php it seems that
the library has overloads for long doubles, but I expect the
implementation treats them as doubles.

But regardless, this is probably not a build issue.

Daniel
_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: [hash] hash_float_test failure

Vladimir Prus
In reply to this post by Caleb Epstein-3
On Monday 13 March 2006 19:03, Caleb Epstein wrote:

> On 3/13/06, Vladimir Prus <[hidden email]> wrote:
> > The functional/hash/has_float_test test fails in CalebEpstein-V2 test
> > results.
> >
> > I suspect that's some Sun-specific floating point accuracy issue.
> >
> > Caleb, can you check if that test works with V1? If so, can you get
> > command
>
> They don't and never have.  There is markup in
> explicit-failures-markup.xmlfor this failure (and similar ones in
> math/octonion_test and
> quaternion_test), but the toolset name was BBv1-style.  I'v corrected this
> in CVS.

Thank you!

Just as a check -- did you add "-sun" to the gcc versions defined in your
user-config.jam? I.e.

  using gcc : 3.4.3-sun : .......

?

Thanks,
Volodya
_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost