explicit-failures-markup.xml

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

explicit-failures-markup.xml

Boost - Dev mailing list
I'm trying to tell the Boost regression matrix that GCC 8 failures are
to be expected using explicit-failures-markup.xml, but it seems to not
be working:

https://www.boost.org/development/tests/master/developer/outcome.html

Here is my explicit-failures-markup.xml:

<?xml version="1.0" encoding="utf-8"?>
<explicit-failures-markup>
    <!-- outcome -->
    <library name="outcome">
        <mark-unusable>
            <toolset name="clang-linux-3*"/>
            <toolset name="gcc-3*"/>
            <toolset name="gcc-4*"/>
            <toolset name="gcc-5*"/>
            <toolset name="gcc-mngw-3*"/>
            <toolset name="gcc-mngw-4*"/>
            <toolset name="gcc-mngw-5*"/>
            <toolset name="msvc-7*"/>
            <toolset name="msvc-8*"/>
            <toolset name="msvc-9*"/>
            <toolset name="msvc-10*"/>
            <toolset name="msvc-11*"/>
            <toolset name="msvc-12*"/>
            <toolset name="msvc-13*"/>
            <toolset name="msvc-14.0.*"/>
            <note author="Niall Douglas">Complete C++14 support is the
minimum requirement.</note>
        </mark-unusable>
        <mark-expected-failures>
            <toolset name="gcc-8*"/>
            <note author="Niall Douglas">GCC 8 currently ICEs with
Outcome's unit tests in C++ 17 or later.</note>
        </mark-expected-failures>
    </library>
</explicit-failures-markup>


What am I doing wrong?

Thanks,
Niall

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: explicit-failures-markup.xml

Boost - Dev mailing list
Niall Douglas wrote:

> I'm trying to tell the Boost regression matrix that GCC 8 failures are to
> be expected using explicit-failures-markup.xml, but it seems to not be
> working:
>
> https://www.boost.org/development/tests/master/developer/outcome.html

...

> What am I doing wrong?

When you update your local explicit-failures-markup.xml, a cron script is
supposed to pick that up and update status/explicit-failures-markup.xml, as
in
https://github.com/boostorg/boost/commit/2acdfb0253a0a9bbab04d700364f330dbd9d027d.

Unfortunately, this doesn't seem to occur in your case for some reason. I
think that the person to contact for this is Daniel James.


_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: explicit-failures-markup.xml

Boost - Dev mailing list
> When you update your local explicit-failures-markup.xml, a cron script
> is supposed to pick that up and update
> status/explicit-failures-markup.xml, as in
> https://github.com/boostorg/boost/commit/2acdfb0253a0a9bbab04d700364f330dbd9d027d.
>
>
> Unfortunately, this doesn't seem to occur in your case for some reason.
> I think that the person to contact for this is Daniel James.

Excellent. I had been beginning to doubt myself as an engineer. I'll
drop him a line.

Niall


_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost