Quantcast

context library of boost: compiling for windows 32 on ubuntu 64

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

context library of boost: compiling for windows 32 on ubuntu 64

Jack Kumba
Hello,

I want to compile libboost_context.a for windows 32 on my ubuntu 64.

for that, I specify the following in my user-config.jam file
using gcc : : "i686-w64-mingw32-g++" ;

and then, I run the following:
b2 --with-context toolset=gcc target-os=windows variant=release link=static address-model=32 binary-format=pe architecture=x86

this gives me the following error:

libs/context/src/unsupported.cpp:7:2: error: #error "platform not supported"
 #error "platform not supported"
  ^

    "i686-w64-mingw32-g++"  -ftemplate-depth-128 -O3 -finline-functions -Wno-inline -Wall -march=i686 -mthreads -m32  -DBOOST_ALL_NO_LIB=1 -DBOOST_CONTEXT_SOURCE -DBOOST_DISABLE_ASSERTS -DNDEBUG  -I"." -c -o "bin.v2/libs/context/build/gcc-mingw-5.3.1/release/binary-format-pe/build-no/link-static/target-os-windows/threading-multi/unsupported.o" "libs/context/src/unsupported.cpp"

...failed gcc.compile.c++ bin.v2/libs/context/build/gcc-mingw-5.3.1/release/binary-format-pe/build-no/link-static/target-os-windows/threading-multi/unsupported.o...

full message is posted here: https://thepasteb.in/p/y8hzcR93o3XO7t2

It seems like the context library of boost is not supported to compile for windows on linux?
Is it the case?

Thanks,
Aja

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost-build
Loading...