compatible Python versions

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

compatible Python versions

Boost - Build mailing list

Hi there,

a user just made me aware of https://github.com/boostorg/build/blob/develop/src/tools/python.jam#L396-L404, which appears to limit *some* functionality to Python versions <=3.4.

Could someone please explain what this means ? What functionality is it that is limited in that way ? And shouldn't the above code be updated to include versions beyond ? (Python is now at version 3.8...)

Thanks,

Stefan
--

      ...ich hab' noch einen Koffer in Berlin...
    

_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build
Reply | Threaded
Open this post in threaded view
|

Re: compatible Python versions

Boost - Build mailing list
On Thu, May 23, 2019 at 9:59 AM stefan via Boost-build <[hidden email]> wrote:

Hi there,

a user just made me aware of https://github.com/boostorg/build/blob/develop/src/tools/python.jam#L396-L404, which appears to limit *some* functionality to Python versions <=3.4.

Could someone please explain what this means ? What functionality is it that is limited in that way ? And shouldn't the above code be updated to include versions beyond ? (Python is now at version 3.8...)

I suspect it's just the effect of time catching up with us. That 34 value was set 6 years ago. And hence version 3.4 seemed like an eternity away at that point. Feel free to post a PR with a new far away value :-)

--
-- Rene Rivera
-- Grafik - Don't Assume Anything
-- Robot Dreams - http://robot-dreams.net


_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build

signature.png (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: compatible Python versions

Boost - Build mailing list


On 2019-05-23 11:39 a.m., Rene Rivera wrote:
On Thu, May 23, 2019 at 9:59 AM stefan via Boost-build <[hidden email]> wrote:

Hi there,

a user just made me aware of https://github.com/boostorg/build/blob/develop/src/tools/python.jam#L396-L404, which appears to limit *some* functionality to Python versions <=3.4.

Could someone please explain what this means ? What functionality is it that is limited in that way ? And shouldn't the above code be updated to include versions beyond ? (Python is now at version 3.8...)

I suspect it's just the effect of time catching up with us. That 34 value was set 6 years ago. And hence version 3.4 seemed like an eternity away at that point. Feel free to post a PR with a new far away value :-)

I don't like working in the blind, so I'd prefer to understand what the code I'm changing was (supposed to be) doing.

Thus my question: what does this code do, and what effect does the current limitation to 3.4 have ? It looks like this only affects Windows and Darwin users. Can you confirm that ?

So far I haven't seen anyone complaining about missing support for Python beyond 3.4. Why not ? If it doesn't matter, why does the code need to be changed at all ? Or in fact, is it perhaps obsolete ?

Thanks,

Stefan
--

      ...ich hab' noch einen Koffer in Berlin...
    

_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build
Reply | Threaded
Open this post in threaded view
|

Re: compatible Python versions

Boost - Build mailing list
On Thu, May 23, 2019 at 10:43 AM stefan <[hidden email]> wrote:


On 2019-05-23 11:39 a.m., Rene Rivera wrote:
On Thu, May 23, 2019 at 9:59 AM stefan via Boost-build <[hidden email]> wrote:

Hi there,

a user just made me aware of https://github.com/boostorg/build/blob/develop/src/tools/python.jam#L396-L404, which appears to limit *some* functionality to Python versions <=3.4.

Could someone please explain what this means ? What functionality is it that is limited in that way ? And shouldn't the above code be updated to include versions beyond ? (Python is now at version 3.8...)

I suspect it's just the effect of time catching up with us. That 34 value was set 6 years ago. And hence version 3.4 seemed like an eternity away at that point. Feel free to post a PR with a new far away value :-)

I don't like working in the blind, so I'd prefer to understand what the code I'm changing was (supposed to be) doing.

Thus my question: what does this code do, and what effect does the current limitation to 3.4 have ? It looks like this only affects Windows and Darwin users. Can you confirm that ?

So far I haven't seen anyone complaining about missing support for Python beyond 3.4. Why not ? If it doesn't matter, why does the code need to be changed at all ? Or in fact, is it perhaps obsolete ?


Since the *-install-python rules are not called. I'm almost certain it's dead code. And hence why no one has complained of not supporting py > 3.4.

--
-- Rene Rivera
-- Grafik - Don't Assume Anything
-- Robot Dreams - http://robot-dreams.net


_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build

signature.png (1K) Download Attachment