[build] b2 headers broken?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[build] b2 headers broken?

Boost - Dev mailing list
Currently all CI seems to be failing during b2 headers, but with no
obvious error message, see for example:
https://drone.cpp.al/boostorg/multiprecision/23/1/2

Only possible thing I can see is:

project-config.jam:10: syntax error at keyword in

Anyone any ideas?

Many thanks, John.


--
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus


_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: [build] b2 headers broken?

Boost - Dev mailing list
Investigating.

On Sat, Jan 16, 2021 at 6:57 AM John Maddock via Boost <
[hidden email]> wrote:

> Currently all CI seems to be failing during b2 headers, but with no
> obvious error message, see for example:
> https://drone.cpp.al/boostorg/multiprecision/23/1/2
>
> Only possible thing I can see is:
>
> project-config.jam:10: syntax error at keyword in
>
> Anyone any ideas?
>
> Many thanks, John.
>
>
> --
> This email has been checked for viruses by Avast antivirus software.
> https://www.avast.com/antivirus
>
>
> _______________________________________________
> Unsubscribe & other changes:
> http://lists.boost.org/mailman/listinfo.cgi/boost
>


--
-- René Ferdinand Rivera Morell
-- Don't Assume Anything  -- No Supone Nada
-- Robot Dreams - http://robot-dreams.net

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: [build] b2 headers broken?

Boost - Dev mailing list
Found the problem.. working on a fix.

On Sat, Jan 16, 2021 at 8:57 AM René Ferdinand Rivera Morell <
[hidden email]> wrote:

> Investigating.
>
> On Sat, Jan 16, 2021 at 6:57 AM John Maddock via Boost <
> [hidden email]> wrote:
>
>> Currently all CI seems to be failing during b2 headers, but with no
>> obvious error message, see for example:
>> https://drone.cpp.al/boostorg/multiprecision/23/1/2
>>
>> Only possible thing I can see is:
>>
>> project-config.jam:10: syntax error at keyword in
>>
>> Anyone any ideas?
>>
>> Many thanks, John.
>>
>>
>> --
>> This email has been checked for viruses by Avast antivirus software.
>> https://www.avast.com/antivirus
>>
>>
>> _______________________________________________
>> Unsubscribe & other changes:
>> http://lists.boost.org/mailman/listinfo.cgi/boost
>>
>
>
> --
> -- René Ferdinand Rivera Morell
> -- Don't Assume Anything  -- No Supone Nada
> -- Robot Dreams - http://robot-dreams.net
>
>

--
-- René Ferdinand Rivera Morell
-- Don't Assume Anything  -- No Supone Nada
-- Robot Dreams - http://robot-dreams.net

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: [build] b2 headers broken?

Boost - Dev mailing list
Fixed <
https://github.com/boostorg/build/commit/69b1c679bbe5b35e8a9afe5cb8f7feae9328e9cd
>

On Sat, Jan 16, 2021 at 9:15 AM René Ferdinand Rivera Morell <
[hidden email]> wrote:

> Found the problem.. working on a fix.
>
> On Sat, Jan 16, 2021 at 8:57 AM René Ferdinand Rivera Morell <
> [hidden email]> wrote:
>
>> Investigating.
>>
>> On Sat, Jan 16, 2021 at 6:57 AM John Maddock via Boost <
>> [hidden email]> wrote:
>>
>>> Currently all CI seems to be failing during b2 headers, but with no
>>> obvious error message, see for example:
>>> https://drone.cpp.al/boostorg/multiprecision/23/1/2
>>>
>>> Only possible thing I can see is:
>>>
>>> project-config.jam:10: syntax error at keyword in
>>>
>>> Anyone any ideas?
>>>
>>> Many thanks, John.
>>>
>>>
>>> --
>>> This email has been checked for viruses by Avast antivirus software.
>>> https://www.avast.com/antivirus
>>>
>>>
>>> _______________________________________________
>>> Unsubscribe & other changes:
>>> http://lists.boost.org/mailman/listinfo.cgi/boost
>>>
>>
>>
>> --
>> -- René Ferdinand Rivera Morell
>> -- Don't Assume Anything  -- No Supone Nada
>> -- Robot Dreams - http://robot-dreams.net
>>
>>
>
> --
> -- René Ferdinand Rivera Morell
> -- Don't Assume Anything  -- No Supone Nada
> -- Robot Dreams - http://robot-dreams.net
>
>

--
-- René Ferdinand Rivera Morell
-- Don't Assume Anything  -- No Supone Nada
-- Robot Dreams - http://robot-dreams.net

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: [build] b2 headers broken?

Boost - Dev mailing list
On Sat, 2021-01-16 at 10:42 -0600, René Ferdinand Rivera Morell via
Boost wrote:

>
> Fixed <
> https://github.com/boostorg/build/commit/69b1c679bbe5b35e8a9afe5cb8f7feae9328e9cd
> >
>
> On Sat, Jan 16, 2021 at 9:15 AM René Ferdinand Rivera Morell <
> [hidden email]> wrote:
>
> > Found the problem.. working on a fix.
> >
> > On Sat, Jan 16, 2021 at 8:57 AM René Ferdinand Rivera Morell <
> > [hidden email]> wrote:
> >
> > > Investigating.
> > >
> > > On Sat, Jan 16, 2021 at 6:57 AM John Maddock via Boost <
> > > [hidden email]> wrote:
> > >
> > > > Currently all CI seems to be failing during b2 headers, but
> > > > with no
> > > > obvious error message, see for example:
> > > > https://drone.cpp.al/boostorg/multiprecision/23/1/2
> > > >
> > > > Only possible thing I can see is:
> > > >
> > > > project-config.jam:10: syntax error at keyword in
> > > >
> > > > Anyone any ideas?
> > > >
> > > > Many thanks, John.
> > > >
> > > >
> > > > --
> > > > This email has been checked for viruses by Avast antivirus
> > > > software.
> > > > https://www.avast.com/antivirus
> > > >
> > > >
> > > > _______________________________________________
> > > > Unsubscribe & other changes:
> > > > http://lists.boost.org/mailman/listinfo.cgi/boost
> > > >
> > >
> > >
> > > --
> > > -- René Ferdinand Rivera Morell
> > > -- Don't Assume Anything  -- No Supone Nada
> > > -- Robot Dreams - http://robot-dreams.net
> > >
> > >
> >
> > --
> > -- René Ferdinand Rivera Morell
> > -- Don't Assume Anything  -- No Supone Nada
> > -- Robot Dreams - http://robot-dreams.net
> >
> >
>
> --
> -- René Ferdinand Rivera Morell
> -- Don't Assume Anything  -- No Supone Nada
> -- Robot Dreams - http://robot-dreams.net
>
> _______________________________________________
> Unsubscribe & other changes:
> http://lists.boost.org/mailman/listinfo.cgi/boost

I am seeing a new failure with that patch:

./tools/build/src/engine/build.sh: 21:
./tools/build/src/engine/build.sh: Bad substitution
Building B2 engine..
./build.sh: 21: ./build.sh: Bad substitution
Failed to build B2 build engine

An example:
https://github.com/boostorg/math/runs/1714388034?check_suite_focus=true#step:11:1

Matt




_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: [build] b2 headers broken?

Boost - Dev mailing list
On Sat, Jan 16, 2021 at 12:17 PM Matt Borland <[hidden email]> wrote:

>
> I am seeing a new failure with that patch:
>

And that's fixed. Hopefully that's the last of the problems on this :-)

--
-- René Ferdinand Rivera Morell
-- Don't Assume Anything  -- No Supone Nada
-- Robot Dreams - http://robot-dreams.net

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost