boost libs compiled for gcc toolset with boost 1.67 and CMake 3.11 won't find libs

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

boost libs compiled for gcc toolset with boost 1.67 and CMake 3.11 won't find libs

Boost - Dev mailing list
Hi,

I discovered that the latest version of boost does not work with CMake when using the GCC toolset. I submitted this bug:

https://gitlab.kitware.com/cmake/cmake/issues/17974#note_408614

Using MSVC as the toolset is fine on windows, but using mingw (gcc compiler) cannot find the libs unless I take out ‘x32’ or ‘x64’ from the name after compilation.

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: boost libs compiled for gcc toolset with boost 1.67 and CMake 3.11 won't find libs

Boost - Dev mailing list
On 8 May 2018 at 15:33, Demetri Kopsas via Boost <[hidden email]> wrote:
> Hi,
>
> I discovered that the latest version of boost does not work with CMake when using the GCC toolset. I submitted this bug:
>
> https://gitlab.kitware.com/cmake/cmake/issues/17974#note_408614
>
> Using MSVC as the toolset is fine on windows, but using mingw (gcc compiler) cannot find the libs unless I take out ‘x32’ or ‘x64’ from the name after compilation.


To clarify, this is CMake / FindBoost.cmake issue, not Boost.

See https://gitlab.kitware.com/cmake/cmake/issues/17701

Best regards,
--
Mateusz Loskot, http://mateusz.loskot.net

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost