boost::chrono problem with gcc-4.6.3

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

boost::chrono problem with gcc-4.6.3

Neo Apostol
Hello everyone.
I use android-ndk (http://www.crystax.net/en/android/ndk/7) with boost-1.49.
My code includes boost::chrono, and when I use gcc-4.4.3 everything goes
fine,
but when I swith on the gcc-4.6.3 (APP_USE_CPP0X := true) so than i get a
strange mistake.

C/C++ Problem 'u16string' in namespace 'std' does not name a type TestCore
 line 243, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp
C/C++ Problem  'u16string' in namespace 'std' does not name a type TestCore
 line 242, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp
C/C++ Problem 'u32string' in namespace 'std' does not name a type TestCore
line 250, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp

C/C++ Problem 'u32string' in namespace 'std' does not name a type TestCore
line 249, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp

C/C++ Problem 'u16string' in namespace 'std' does not name a type TestCore
line 287, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp

C/C++ Problem 'u16string' in namespace 'std' does not name a type TestCore
line 286, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp

C/C++ Problem 'u32string' in namespace 'std' does not name a type TestCore
line 294, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp

C/C++ Problem 'u32string' in namespace 'std' does not name a type TestCore
line 293, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp

C/C++ Problem 'u16string' in namespace 'std' does not name a type TestCore
line 331, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp

C/C++ Problem 'u16string' in namespace 'std' does not name a type TestCore
line 330, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp

C/C++ Problem 'u32string' in namespace 'std' does not name a type TestCore
line 338, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp

C/C++ Problem 'u32string' in namespace 'std' does not name a type TestCore
line 337, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp

C/C++ Problem 'u16string' in namespace 'std' does not name a type TestCore
line 375, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp

C/C++ Problem 'u16string' in namespace 'std' does not name a type TestCore
line 374, external location:
/Users/user/Mobile/android-ndk-crystax/sources/boost/boost/ratio/ratio_io.hpp
...............................................

Does somebody can help me?

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: boost::chrono problem with gcc-4.6.3

Vicente Botet
Neo Apostol wrote
Hello everyone.
I use android-ndk (http://www.crystax.net/en/android/ndk/7) with boost-1.49.
My code includes boost::chrono, and when I use gcc-4.4.3 everything goes
fine,
but when I swith on the gcc-4.6.3 (APP_USE_CPP0X := true) so than i get a
strange mistake.

Does somebody can help me?
Hi,

there was a simple fix for #6241 boost::chrono compilation problems without std::wstring support. (https://svn.boost.org/trac/boost/ticket/6241) applied on 1.51.

It is useful to look at the history of the library
http://www.boost.org/doc/libs/1_52_0/doc/html/chrono/appendices.html#chrono.appendices.history
or the the history of the releases 1.51 : http://www.boost.org/users/history/version_1_51_0.html.

HTH,
Vicente
Reply | Threaded
Open this post in threaded view
|

Re: boost::chrono problem with gcc-4.6.3

Vicente Botet
Vicente Botet wrote
Neo Apostol wrote
Hello everyone.
I use android-ndk (http://www.crystax.net/en/android/ndk/7) with boost-1.49.
My code includes boost::chrono, and when I use gcc-4.4.3 everything goes
fine,
but when I swith on the gcc-4.6.3 (APP_USE_CPP0X := true) so than i get a
strange mistake.

Does somebody can help me?
Hi,

there was a simple fix for #6241 boost::chrono compilation problems without std::wstring support. (https://svn.boost.org/trac/boost/ticket/6241) applied on 1.51.

It is useful to look at the history of the library
http://www.boost.org/doc/libs/1_52_0/doc/html/chrono/appendices.html#chrono.appendices.history
or the the history of the releases 1.51 : http://www.boost.org/users/history/version_1_51_0.html.

HTH,
Vicente

Sorry the bug was

#7478 Compiles fails with compilers supporting char16_t and char32_t fails if the library doesn't provides std::u16string and std::u32string.

Vicente