Quantcast

Visual Studio multi-toolset support (was: [release] 1.64.0 please test master snapshot)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Visual Studio multi-toolset support (was: [release] 1.64.0 please test master snapshot)

Boost - Dev mailing list
On 18 March 2017 at 14:27, Peter Dimov via Boost <[hidden email]> wrote:

> Mateusz Loskot wrote:
>
>>> No, VS 2015 can build with v140, v120, v110, v100, v90, as long as you
>>> have the earlier versions installed. (VS 2017 can build with v140 even if
>>> you don't have VS 2015 installed.)
>>
>>
>> I understood VS2017 is first version with multi-toolset support.
>
>
> The first version with multi-toolset support is VS 2012, although the only
> two toolsets supported are v110 and v110_xp, which share the same version.
> VS 2013 supports v90 - v120. VS 2015 supports v90 - v140.

I always used the 'default' toolset of particular VS version,
hence fostered ignorance about that multi-toolset support.

> Wait, no, VS 2010 supports v100 and v90. :-)

:-)

Thank you for the enlightenment.

Best regards,
--
Mateusz Loskot, http://mateusz.loskot.net

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Loading...