VS 2017 15.6 released, _MSC_VER=1913...

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

VS 2017 15.6 released, _MSC_VER=1913...

Boost - Dev mailing list
... and Boost.Config once again warns:

1>c:\boost-git\develop\boost\config\compiler\visualc.hpp(349): note: Info:
Boost.Config is older than your compiler version - probably nothing bad will
happen - but you may wish to look for an updated Boost version. Define
BOOST_CONFIG_SUPPRESS_OUTDATED_MESSAGE to suppress this message.

Maybe we should display this only on 1920 and above, as I suggested last
time? :-)


_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: VS 2017 15.6 released, _MSC_VER=1913...

Boost - Dev mailing list
> -----Original Message-----
> From: Boost <[hidden email]> On Behalf Of Peter Dimov via
> Boost
> Sent: Mittwoch, 7. März 2018 00:40
> To: boost-devel <[hidden email]>
> Cc: Peter Dimov <[hidden email]>
> Subject: [boost] VS 2017 15.6 released, _MSC_VER=1913...
>
> ... and Boost.Config once again warns:
>
> 1>c:\boost-git\develop\boost\config\compiler\visualc.hpp(349): note: Info:
> Boost.Config is older than your compiler version - probably nothing bad will
> happen - but you may wish to look for an updated Boost version. Define
> BOOST_CONFIG_SUPPRESS_OUTDATED_MESSAGE to suppress this
> message.
>
> Maybe we should display this only on 1920 and above, as I suggested last
> time? :-)

Yes please! With these frequent _MSC_VER bumps, anyone who cares about
compiler messages has no option but to define the above macro.

Marcel


_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: VS 2017 15.6 released, _MSC_VER=1913...

Boost - Dev mailing list
In reply to this post by Boost - Dev mailing list
On 7 March 2018 at 00:40, Peter Dimov via Boost <[hidden email]> wrote:
> ... and Boost.Config once again warns:
>
> 1>c:\boost-git\develop\boost\config\compiler\visualc.hpp(349): note: Info:
> Boost.Config is older than your compiler version - probably nothing bad will
> happen - but you may wish to look for an updated Boost version. Define
> BOOST_CONFIG_SUPPRESS_OUTDATED_MESSAGE to suppress this message.
>
> Maybe we should display this only on 1920 and above, as I suggested last
> time? :-)

+1


Would it be also possible to include a minimal instruction in
"Unknown compiler version - please run the configure tests and report
the results"
in how to such "run the configure tests"?

Best regards,
--
Mateusz Loskot, http://mateusz.loskot.net

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: VS 2017 15.6 released, _MSC_VER=1913...

Boost - Dev mailing list
On Wed, Mar 7, 2018 at 11:13 AM, Mateusz Loskot via Boost
<[hidden email]> wrote:

> On 7 March 2018 at 00:40, Peter Dimov via Boost <[hidden email]> wrote:
>> ... and Boost.Config once again warns:
>>
>> 1>c:\boost-git\develop\boost\config\compiler\visualc.hpp(349): note: Info:
>> Boost.Config is older than your compiler version - probably nothing bad will
>> happen - but you may wish to look for an updated Boost version. Define
>> BOOST_CONFIG_SUPPRESS_OUTDATED_MESSAGE to suppress this message.
>>
>> Maybe we should display this only on 1920 and above, as I suggested last
>> time? :-)
>
> +1
>
>
> Would it be also possible to include a minimal instruction in
> "Unknown compiler version - please run the configure tests and report
> the results"
> in how to such "run the configure tests"?

How to report would be nice to know too. ;)


--
Olaf

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: VS 2017 15.6 released, _MSC_VER=1913...

Boost - Dev mailing list
On 7 March 2018 at 11:20, Olaf van der Spek <[hidden email]> wrote:

> On Wed, Mar 7, 2018 at 11:13 AM, Mateusz Loskot via Boost
> <[hidden email]> wrote:
>> On 7 March 2018 at 00:40, Peter Dimov via Boost <[hidden email]> wrote:
>>> ... and Boost.Config once again warns:
>>>
>>> 1>c:\boost-git\develop\boost\config\compiler\visualc.hpp(349): note: Info:
>>> Boost.Config is older than your compiler version - probably nothing bad will
>>> happen - but you may wish to look for an updated Boost version. Define
>>> BOOST_CONFIG_SUPPRESS_OUTDATED_MESSAGE to suppress this message.
>>>
>>> Maybe we should display this only on 1920 and above, as I suggested last
>>> time? :-)
>>
>> +1
>>
>>
>> Would it be also possible to include a minimal instruction in
>> "Unknown compiler version - please run the configure tests and report
>> the results"
>> in how to such "run the configure tests"?
>
> How to report would be nice to know too. ;)

Although I assumed "to report" means go to https://github.com/boostorg/config
and open an issue, but no-brainer instruction is always a winner :)

Best regards,
--
Mateusz Loskot, http://mateusz.loskot.net

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|

Re: VS 2017 15.6 released, _MSC_VER=1913...

Boost - Dev mailing list
In reply to this post by Boost - Dev mailing list


On 07/03/2018 10:13, Mateusz Loskot via Boost wrote:

> On 7 March 2018 at 00:40, Peter Dimov via Boost <[hidden email]> wrote:
>> ... and Boost.Config once again warns:
>>
>> 1>c:\boost-git\develop\boost\config\compiler\visualc.hpp(349): note: Info:
>> Boost.Config is older than your compiler version - probably nothing bad will
>> happen - but you may wish to look for an updated Boost version. Define
>> BOOST_CONFIG_SUPPRESS_OUTDATED_MESSAGE to suppress this message.
>>
>> Maybe we should display this only on 1920 and above, as I suggested last
>> time? :-)
> +1
>
>
> Would it be also possible to include a minimal instruction in
> "Unknown compiler version - please run the configure tests and report
> the results"
> in how to such "run the configure tests"?

That message is a release out of date.

In any case, I give in, message disabled.

John.

---
This email has been checked for viruses by AVG.
http://www.avg.com


_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost