Regression Tests Failures - Predef

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Regression Tests Failures - Predef

Boost - Testing mailing list
Sometime between 3-6AM central time today a change was checked in that is causing all the regression tests I run (Windows/Visual Studio + Linux/GCC+Clang on both master and develop) to fail. They all have the following at the end of their results file:

notice: [lzma] lzma is already configured 
error: at ../libs/predef/test/build.jam:47 
error: Attempt to redeclare already registered project id '/test'. 
error: Original project: 
error:     Name: Jamfile</var/boost/run/boost_root/libs/beast/test> 
error:     Module: Jamfile</var/boost/run/boost_root/libs/beast/test> 
error:     Main id: /test 
error:     File: ../libs/beast/test/Jamfile 
error:     Location: ../libs/beast/test 
error: New project: 
error:     Module: Jamfile</var/boost/run/boost_root/libs/predef/test> 
error:     File: ../libs/predef/test/build.jam 
error:     Location: ../libs/predef/test

Tom

_______________________________________________
Boost-Testing mailing list
[hidden email]
https://lists.boost.org/mailman/listinfo.cgi/boost-testing

org.kde.konsole.desktop (11K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Regression Tests Failures - Predef

Boost - Testing mailing list
AMDG

On 08/01/2017 10:50 AM, Tom Kent via Boost-Testing wrote:

> Sometime between 3-6AM central time today a change was checked in that is
> causing all the regression tests I run (Windows/Visual Studio +
> Linux/GCC+Clang on both master and develop) to fail. They all have the
> following at the end of their results file:
>
> notice: [lzma] lzma is already configured
> error: at ../libs/predef/test/build.jam:47
> error: Attempt to redeclare already registered project id '/test'.
> error: Original project:
> error:     Name: Jamfile</var/boost/run/boost_root/libs/beast/test>
> error:     Module: Jamfile</var/boost/run/boost_root/libs/beast/test>
> error:     Main id: /test
> error:     File: ../libs/beast/test/Jamfile
> error:     Location: ../libs/beast/test
> error: New project:
> error:     Module: Jamfile</var/boost/run/boost_root/libs/predef/test>
> error:     File: ../libs/predef/test/build.jam
> error:     Location: ../libs/predef/test
>

Project IDs are required to be globally unique.
Instead of using
project /test ;
it should be
project /boost/predef/test ;
project /boost/beast/test ;

In Christ,
Steven Watanabe

_______________________________________________
Boost-Testing mailing list
[hidden email]
https://lists.boost.org/mailman/listinfo.cgi/boost-testing
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Regression Tests Failures - Predef

Boost - Testing mailing list
On 1 August 2017 at 18:10, Steven Watanabe via Boost-Testing
<[hidden email]> wrote:
>
> Project IDs are required to be globally unique.
> Instead of using
> project /test ;
> it should be
> project /boost/predef/test ;
> project /boost/beast/test ;

I'm creating some pull requests to do that. Although, I noticed a lot
of modules don't name their test project so maybe it's easier not to
name them.
_______________________________________________
Boost-Testing mailing list
[hidden email]
https://lists.boost.org/mailman/listinfo.cgi/boost-testing
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Regression Tests Failures - Predef

Boost - Testing mailing list
In reply to this post by Boost - Testing mailing list
On Tue, Aug 1, 2017 at 10:10 AM, Steven Watanabe via Boost-Testing <[hidden email]> wrote:
AMDG

On 08/01/2017 10:50 AM, Tom Kent via Boost-Testing wrote:
> Sometime between 3-6AM central time today a change was checked in that is
> causing all the regression tests I run (Windows/Visual Studio +
> Linux/GCC+Clang on both master and develop) to fail. They all have the
> following at the end of their results file:
>
> notice: [lzma] lzma is already configured
> error: at ../libs/predef/test/build.jam:47
> error: Attempt to redeclare already registered project id '/test'.
> error: Original project:
> error:     Name: Jamfile</var/boost/run/boost_root/libs/beast/test>
> error:     Module: Jamfile</var/boost/run/boost_root/libs/beast/test>
> error:     Main id: /test
> error:     File: ../libs/beast/test/Jamfile
> error:     Location: ../libs/beast/test
> error: New project:
> error:     Module: Jamfile</var/boost/run/boost_root/libs/predef/test>
> error:     File: ../libs/predef/test/build.jam
> error:     Location: ../libs/predef/test
>

I am seeing this as well.
 

Project IDs are required to be globally unique.
Instead of using
project /test ;
it should be
project /boost/predef/test ;
project /boost/beast/test ;


Then they should be fixed in both predef and beast.

-- Marshall
 


_______________________________________________
Boost-Testing mailing list
[hidden email]
https://lists.boost.org/mailman/listinfo.cgi/boost-testing
Loading...