Problem running regression tests

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem running regression tests

Edward Diener-3
I am running regression tests on Windows from the directory
c:\programming\BoostRegression. When I run the regression tests I get
the error:

c:\Programming\BoostRegression\boost_root\status>"c:\Programming\BoostRegression
\boost_bb\src\engine\bin.ntx86\bjam.exe"
"-sBOOST_BUILD_PATH=c:\Programming\Boos
tRegression;c:\Programming\BoostRegression\boost_bb\src"
"-sBOOST_ROOT=c:\Progra
mming\BoostRegression\boost_root"
"--boost=c:\Programming\BoostRegression\boost_
root" "--boost-root=c:\Programming\BoostRegression\boost_root"
"--boost-build=c:
\Programming\BoostRegression\boost_bb\src" "--debug-configuration" -l300
toolse
t=gcc-4.8,gcc-4.9,gcc-5.1,gcc-5.2,gcc-5.3 -d2 preserve-test-targets=off
--dump-t
ests  -m64 "--build-dir=c:\Programming\BoostRegression\results"
1>>"c:\Programm
ing\BoostRegression\results\bjam.log" 2>&1
# Running Boost.Build tests
Traceback (most recent call last):
   File "run.py", line 71, in <module>
     runner(root)
   File
"c:\Programming\BoostRegression\boost_regression_src\regression.py", line
  287, in __init__
     self.main()
   File
"c:\Programming\BoostRegression\boost_regression_src\regression.py", line
  624, in main
     getattr(self,action_m)()
   File
"c:\Programming\BoostRegression\boost_regression_src\regression.py", line
  589, in command_regression
     self.command_test()
   File
"c:\Programming\BoostRegression\boost_regression_src\regression.py", line
  368, in command_test
     self.command_test_boost_build()
   File
"c:\Programming\BoostRegression\boost_regression_src\regression.py", line
  410, in command_test_boost_build
     "boost/bin.v2/libs/any/test/any_test.test"));
WindowsError: [Error 3] The system cannot find the path specified":
'c:\\Programm
ing\\BoostRegression\\results\\boost/bin.v2/libs/any/test/any_test.test/*.*'

There is no c:\programming\BoostRegression\results\boost\bin.v2\libs\any
directory generated.
_______________________________________________
Boost-Testing mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-testing
Reply | Threaded
Open this post in threaded view
|

Re: Problem running regression tests

Steven Watanabe-4
AMDG

On 01/06/2016 08:45 AM, Edward Diener wrote:
> I am running regression tests on Windows from the directory
> c:\programming\BoostRegression. When I run the regression tests I get
> the error:
>

This usually means that Boost.Build aborted without
doing anything.  Check bjam.log.

> c:\Programming\BoostRegression\boost_root\status>"c:\Programming\BoostRegression
>
> \boost_bb\src\engine\bin.ntx86\bjam.exe"
> "-sBOOST_BUILD_PATH=c:\Programming\Boos
> tRegression;c:\Programming\BoostRegression\boost_bb\src"
> "-sBOOST_ROOT=c:\Progra
> mming\BoostRegression\boost_root"
> "--boost=c:\Programming\BoostRegression\boost_
> root" "--boost-root=c:\Programming\BoostRegression\boost_root"
> "--boost-build=c:
> \Programming\BoostRegression\boost_bb\src" "--debug-configuration" -l300
> toolse
> t=gcc-4.8,gcc-4.9,gcc-5.1,gcc-5.2,gcc-5.3 -d2 preserve-test-targets=off
> --dump-t
> ests  -m64 "--build-dir=c:\Programming\BoostRegression\results"
> 1>>"c:\Programm
> ing\BoostRegression\results\bjam.log" 2>&1
> <snip>
> WindowsError: [Error 3] The system cannot find the path specified":
> 'c:\\Programm
> ing\\BoostRegression\\results\\boost/bin.v2/libs/any/test/any_test.test/*.*'
>

In Christ,
Steven Watanabe

_______________________________________________
Boost-Testing mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-testing