Missing concept_check tests?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing concept_check tests?

Vladimir Prus

Hi,
when I look at
http://engineering.meta-comm.com/boost-regression/CVS-HEAD/developer/concept_check.html,
I see three tests.

when I look at libs/concept_check/Jamfile.v2, CVS HEAD as of today, I see 5
tests:

test-suite concept_check
  : [ compile stl_concept_covering.cpp ]
    [ compile concept_check_test.cpp  ]
    [ compile class_concept_check_test.cpp ]
    [ link-fail concept_check_fail_expected.cpp ]
    [ link-fail class_concept_fail_expected.cpp ]
  ;

It appears the "link-fail" tests are not reported. Any hints? If that helps,
the tests in question fail to compile, as opposed to fail to link, maybe
that's the problem?

- Volodya


_______________________________________________
Boost-Testing mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-testing
Reply | Threaded
Open this post in threaded view
|

Re: Missing concept_check tests?

Eric Niebler

Vladimir Prus wrote:
> It appears the "link-fail" tests are not reported. Any hints? If that helps,
> the tests in question fail to compile, as opposed to fail to link, maybe
> that's the problem?


I've noticed this problem, too. xpressive also has a link test that is
not showing up in the regression report. Could be a general problem.


--
Eric Niebler
Boost Consulting
www.boost-consulting.com
_______________________________________________
Boost-Testing mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-testing