Error Uploading Test Report

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Error Uploading Test Report

Tom Kent
I just happened to notice that the results were stale this morning, and then when to check my report runner. It was running normally, but at the end of each run it fails to upload, with a different error message than the previous "out of space" we encountered...

riting runner document teeks99-09j-win2012R2-64on64.html
Writing runner document teeks99-09k-win2012R2-64on64.html
Writing runner document teeks99-09l-win2012R2-64on64.html
Writing file master.css
develop.zip.tomkent.uploading
rsync: [sender] write error: Broken pipe (32)
inflate returned -3 (0 bytes)
rsync error: error in rsync protocol data stream (code 12) at token.c(547) [receiver=3.0.6]
rsync error: error in rsync protocol data stream (code 12) at io.c(837) [sender=3.1.0]
tomkent@jimbo:~/tmp/boost_reports

Thoughts?
Tom

_______________________________________________
Boost-Testing mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-testing
Reply | Threaded
Open this post in threaded view
|

Re: Error Uploading Test Report

Rene Rivera-2
On Tue, Jan 24, 2017 at 7:59 AM, Tom Kent <[hidden email]> wrote:
I just happened to notice that the results were stale this morning, and then when to check my report runner. It was running normally, but at the end of each run it fails to upload, with a different error message than the previous "out of space" we encountered...

riting runner document teeks99-09j-win2012R2-64on64.html
Writing runner document teeks99-09k-win2012R2-64on64.html
Writing runner document teeks99-09l-win2012R2-64on64.html
Writing file master.css
develop.zip.tomkent.uploading
rsync: [sender] write error: Broken pipe (32)
inflate returned -3 (0 bytes)
rsync error: error in rsync protocol data stream (code 12) at token.c(547) [receiver=3.0.6]
rsync error: error in rsync protocol data stream (code 12) at io.c(837) [sender=3.1.0]
tomkent@jimbo:~/tmp/boost_reports

Thoughts?

No idea. And nothing comes in a web search for that. I'll check if the same happens when I run it locally.


--
-- Rene Rivera
-- Grafik - Don't Assume Anything
-- Robot Dreams - http://robot-dreams.net
-- rrivera/acm.org (msn) - grafikrobot/aim,yahoo,skype,efnet,gmail

_______________________________________________
Boost-Testing mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-testing
Reply | Threaded
Open this post in threaded view
|

Re: Error Uploading Test Report

Rene Rivera-2
On Sun, Jan 29, 2017 at 11:43 AM, Rene Rivera <[hidden email]> wrote:
On Tue, Jan 24, 2017 at 7:59 AM, Tom Kent <[hidden email]> wrote:
I just happened to notice that the results were stale this morning, and then when to check my report runner. It was running normally, but at the end of each run it fails to upload, with a different error message than the previous "out of space" we encountered...

riting runner document teeks99-09j-win2012R2-64on64.html
Writing runner document teeks99-09k-win2012R2-64on64.html
Writing runner document teeks99-09l-win2012R2-64on64.html
Writing file master.css
develop.zip.tomkent.uploading
rsync: [sender] write error: Broken pipe (32)
inflate returned -3 (0 bytes)
rsync error: error in rsync protocol data stream (code 12) at token.c(547) [receiver=3.0.6]
rsync error: error in rsync protocol data stream (code 12) at io.c(837) [sender=3.1.0]
tomkent@jimbo:~/tmp/boost_reports

Thoughts?

No idea. And nothing comes in a web search for that. I'll check if the same happens when I run it locally.

I don't get that error after trying multiple times, and succeeding, to post reports. I've deleted the current upload files to see if that kicks your process into working.


--
-- Rene Rivera
-- Grafik - Don't Assume Anything
-- Robot Dreams - http://robot-dreams.net
-- rrivera/acm.org (msn) - grafikrobot/aim,yahoo,skype,efnet,gmail

_______________________________________________
Boost-Testing mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-testing
Reply | Threaded
Open this post in threaded view
|

Re: Error Uploading Test Report

Rene Rivera-2


On Sun, Jan 29, 2017 at 6:06 PM, Rene Rivera <[hidden email]> wrote:
On Sun, Jan 29, 2017 at 11:43 AM, Rene Rivera <[hidden email]> wrote:
On Tue, Jan 24, 2017 at 7:59 AM, Tom Kent <[hidden email]> wrote:
I just happened to notice that the results were stale this morning, and then when to check my report runner. It was running normally, but at the end of each run it fails to upload, with a different error message than the previous "out of space" we encountered...

riting runner document teeks99-09j-win2012R2-64on64.html
Writing runner document teeks99-09k-win2012R2-64on64.html
Writing runner document teeks99-09l-win2012R2-64on64.html
Writing file master.css
develop.zip.tomkent.uploading
rsync: [sender] write error: Broken pipe (32)
inflate returned -3 (0 bytes)
rsync error: error in rsync protocol data stream (code 12) at token.c(547) [receiver=3.0.6]
rsync error: error in rsync protocol data stream (code 12) at io.c(837) [sender=3.1.0]
tomkent@jimbo:~/tmp/boost_reports

Thoughts?

No idea. And nothing comes in a web search for that. I'll check if the same happens when I run it locally.

I don't get that error after trying multiple times, and succeeding, to post reports. I've deleted the current upload files to see if that kicks your process into working.

After removing the inbound report files I haven't see any new uploads. Are you still having the problem? Or you have the reporting turned off?


--
-- Rene Rivera
-- Grafik - Don't Assume Anything
-- Robot Dreams - http://robot-dreams.net
-- rrivera/acm.org (msn) - grafikrobot/aim,yahoo,skype,efnet,gmail

_______________________________________________
Boost-Testing mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-testing
Reply | Threaded
Open this post in threaded view
|

Re: Error Uploading Test Report

Tom Kent


On Mon, Jan 30, 2017 at 11:22 AM, Rene Rivera <[hidden email]> wrote:


On Sun, Jan 29, 2017 at 6:06 PM, Rene Rivera <[hidden email]> wrote:
On Sun, Jan 29, 2017 at 11:43 AM, Rene Rivera <[hidden email]> wrote:
On Tue, Jan 24, 2017 at 7:59 AM, Tom Kent <[hidden email]> wrote:
I just happened to notice that the results were stale this morning, and then when to check my report runner. It was running normally, but at the end of each run it fails to upload, with a different error message than the previous "out of space" we encountered...

riting runner document teeks99-09j-win2012R2-64on64.html
Writing runner document teeks99-09k-win2012R2-64on64.html
Writing runner document teeks99-09l-win2012R2-64on64.html
Writing file master.css
develop.zip.tomkent.uploading
rsync: [sender] write error: Broken pipe (32)
inflate returned -3 (0 bytes)
rsync error: error in rsync protocol data stream (code 12) at token.c(547) [receiver=3.0.6]
rsync error: error in rsync protocol data stream (code 12) at io.c(837) [sender=3.1.0]
tomkent@jimbo:~/tmp/boost_reports

Thoughts?

No idea. And nothing comes in a web search for that. I'll check if the same happens when I run it locally.

I don't get that error after trying multiple times, and succeeding, to post reports. I've deleted the current upload files to see if that kicks your process into working.

After removing the inbound report files I haven't see any new uploads. Are you still having the problem? Or you have the reporting turned off?

Restarted and things look good. 

I'm happy to provide the report processing, however when we get a new VM setup from rackspace for test results with all the other hosting that has been discussed, maybe we could run this job on there? Any thoughts on that?

Tom 

_______________________________________________
Boost-Testing mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-testing
Reply | Threaded
Open this post in threaded view
|

Re: Error Uploading Test Report

Rene Rivera-2
On Mon, Jan 30, 2017 at 6:42 PM, Tom Kent <[hidden email]> wrote:

Restarted and things look good. 

I'm happy to provide the report processing, however when we get a new VM setup from rackspace for test results with all the other hosting that has been discussed, maybe we could run this job on there? Any thoughts on that?

We might be able to do that. But I'd have to consult with them to see if there's capacity there. If not we can look into expanding capacity to allow it. I've also been trying to see if we can run it on one of the CI services. The hurdle there is I don't know what space limits they have. And also if the task would finish within their time limits. What specs are the VM you use now? And how long does it take to do one update?


--
-- Rene Rivera
-- Grafik - Don't Assume Anything
-- Robot Dreams - http://robot-dreams.net
-- rrivera/acm.org (msn) - grafikrobot/aim,yahoo,skype,efnet,gmail

_______________________________________________
Boost-Testing mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-testing