Compile Error spirit.x3 after update

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Compile Error spirit.x3 after update

Klemens Morgenstern
Hi,

I've got a strange error after upgrading my spirit.x3 version, you can
see the code and error here:
http://coliru.stacked-crooked.com/a/684177d5b6d00f76

Sorry that I don't have a simpler example, but many of my simpler rules
are affected by that (but they use many others, so it's not a simple
example).

Basically, I get an errror like this: no type named 'type' in 'struct
boost::spirit::x3::traits::container_value<boost::fusion::iterator_range<
/*a long list of types */>, void>'

This affects most of my rules, which is quite problematic; I've tried it
with the newest commit on the develop and master branch, they all give
the same error. If I check out
"d5a11a415620869ec8c883aa52e984e60dd27e99" it works, though I'm not sure
if this is the one causing the error.

I hope that wasn't asked before, because it seems quite strange, that
only I get this problem.

Thanks,

Klemens


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Spirit-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/spirit-general