Building library with vc++ 64-bit does not find vcvarsall.bat

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Building library with vc++ 64-bit does not find vcvarsall.bat

Boost - Build mailing list
If I build any library with any version vc++ 64-bit compiler, by using
address-model=64, the vcvarsall.bat is looked for at, for example with
msvc-14.0, C:/Program Files (x86)/Microsoft Visual Studio
14.0/VC/bin/vcvarsall.bat and is not found. Naturally this leads to
basic compilation failures. The path for vcvarsall.bat for msvc-14.0 is
C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/vcvarsall.bat
instead. All versions of vc++ follow this path structure for vcvarsall.bat

Building with any version of vc++ 32-bit, by not specifying the
address-model, works correctly.

_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build
Reply | Threaded
Open this post in threaded view
|

Re: Building library with vc++ 64-bit does not find vcvarsall.bat

Boost - Build mailing list
On 10/13/2017 4:26 PM, Edward Diener via Boost-build wrote:

> If I build any library with any version vc++ 64-bit compiler, by using
> address-model=64, the vcvarsall.bat is looked for at, for example with
> msvc-14.0, C:/Program Files (x86)/Microsoft Visual Studio
> 14.0/VC/bin/vcvarsall.bat and is not found. Naturally this leads to
> basic compilation failures. The path for vcvarsall.bat for msvc-14.0 is
> C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/vcvarsall.bat
> instead. All versions of vc++ follow this path structure for vcvarsall.bat
>
> Building with any version of vc++ 32-bit, by not specifying the
> address-model, works correctly.

After rebuilding b2 everything is working correctly.

_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build