Boost, STLport, and Visual Studio 2005

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Boost, STLport, and Visual Studio 2005

Robert S. Grimes
Hi all,

Trying to get Boost 1.33.1 and STLport 5.0.1 to co-exist under Micro$oft
Visual Studio 2005.  I got them both to apparently compile and install okay,
but when I attempt a Boost::Serialization test, I run into a problem:

LINK : fatal error LNK1104: cannot open file
'libboost_serialization-vc80-mt-gdp-1_33_1.lib'

>From the docs, I indeed find that the "-gdp-" library is non-existent;
specifically, the 'p' for STLport is missing.  How do I build the STLport
runtimes?

Thanks!
-RSG
_______________________________________________
Boost-users mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-users
Reply | Threaded
Open this post in threaded view
|

Re: Boost, STLport, and Visual Studio 2005

John Maddock
> Trying to get Boost 1.33.1 and STLport 5.0.1 to co-exist under
> Micro$oft Visual Studio 2005.  I got them both to apparently compile
> and install okay, but when I attempt a Boost::Serialization test, I
> run into a problem:
>
> LINK : fatal error LNK1104: cannot open file
> 'libboost_serialization-vc80-mt-gdp-1_33_1.lib'
>
>> From the docs, I indeed find that the "-gdp-" library is
>> non-existent;
> specifically, the 'p' for STLport is missing.  How do I build the
> STLport runtimes?

Unfortunately we don't have a vc8+stlport toolset yet.  Probably the easiest
way would be to:

1) Define BOOST_ALL_NO_LIB when building your code so that auto-linking is
suppressed.

2) Build the libraries your interested in from your IDE: for the most part
they're "just a bunch of sources".

John.

_______________________________________________
Boost-users mailing list
[hidden email]
http://lists.boost.org/mailman/listinfo.cgi/boost-users