Boost.Build 1.73.0 Error

Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Boost.Build 1.73.0 Error

Boost - Build mailing list
Installed boost and then tried example...
/usr/include/boost_1_73_0/build-develop/example/hello

Looking for input on...
How to solve this error after installing latest version boost (1.73.0)?

ERROR: rule "[[bbv2.builtin.features.warnings]]`warnings`::" unknown in module "warnings-feature".

If I remove the block comments in warnings-feature.jam the error simply propogates to next jam file with block comment.

Only thing I can find online is suggestion that may not be using latest version of boost.build as error suggestive that b2 does not understand block comments.


Below is boost version and boost.build version after install...

$ cat /usr/include/boost_1_73_0/boost/version.hpp | grep "BOOST_LIB_VERSION"
//  BOOST_LIB_VERSION must be defined to be the same as BOOST_VERSION
#define BOOST_LIB_VERSION "1_73"

$ b2 -v
Boost.Jam  Version 2015.07. OS=LINUX.
   Copyright 1993-2002 Christopher Seiwald and Perforce Software, Inc.
   Copyright 2001 David Turner.
   Copyright 2001-2004 David Abrahams.
   Copyright 2002-2015 Rene Rivera.
   Copyright 2003-2015 Vladimir Prus.

Thanks in advance

Dennis

_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build
Reply | Threaded
Open this post in threaded view
|

Re: Boost.Build 1.73.0 Error

Boost - Build mailing list
On Fri, May 8, 2020 at 1:52 AM Dennis Hart via Boost-build <[hidden email]> wrote:
Installed boost and then tried example...
/usr/include/boost_1_73_0/build-develop/example/hello

Looking for input on...
How to solve this error after installing latest version boost (1.73.0)?

ERROR: rule "[[bbv2.builtin.features.warnings]]`warnings`::" unknown in module "warnings-feature".

If I remove the block comments in warnings-feature.jam the error simply propogates to next jam file with block comment.

Only thing I can find online is suggestion that may not be using latest version of boost.build as error suggestive that b2 does not understand block comments.


Below is boost version and boost.build version after install...

$ cat /usr/include/boost_1_73_0/boost/version.hpp | grep "BOOST_LIB_VERSION"
//  BOOST_LIB_VERSION must be defined to be the same as BOOST_VERSION
#define BOOST_LIB_VERSION "1_73"

$ b2 -v
Boost.Jam  Version 2015.07. OS=LINUX.
   Copyright 1993-2002 Christopher Seiwald and Perforce Software, Inc.
   Copyright 2001 David Turner.
   Copyright 2001-2004 David Abrahams.
   Copyright 2002-2015 Rene Rivera.
   Copyright 2003-2015 Vladimir Prus.

Thanks in advance

As your research has revealed, you are using an outdated b2 version instead of the one that is included in the distribution. The one in the distribution says:

===
$ ./b2 -v
B2 Version 4.2. OS=LINUX.
  Copyright 1993-2002 Christopher Seiwald and Perforce Software, Inc.
  Copyright 2001 David Turner.
  Copyright 2001-2004 David Abrahams.
  Copyright 2002-2019 Rene Rivera.
  Copyright 2003-2015 Vladimir Prus.
===

HTH

--
-- Rene Rivera
-- Grafik - Don't Assume Anything
-- Robot Dreams - http://robot-dreams.net


_______________________________________________
Unsubscribe & other changes: https://lists.boost.org/mailman/listinfo.cgi/boost-build