Boost.Accumulators regression in Boost 1.71 beta 1 on VC++17/19

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Boost.Accumulators regression in Boost 1.71 beta 1 on VC++17/19

Boost - Dev mailing list
Hello,
    the attached minimal file fails to compile on VC++17/19 when using
Boost 1.71.0b1.  It compiles successfully with Boost 1.70.0.  I also attach
the compiler errors.

Cheers,
    Luigi


_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost

errors.txt (43K) Download Attachment
test.cpp (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Boost.Accumulators regression in Boost 1.71 beta 1 on VC++17/19

Boost - Dev mailing list
This turns out to be a duplicate of <
https://lists.boost.org/Archives/boost/2019/08/246711.php>.  As suggested
in that thread, the solution is to merge <
https://github.com/boostorg/accumulators/pull/30> before release.

Cheers,
    Luigi


On Sat, Aug 3, 2019 at 11:40 AM Luigi Ballabio <[hidden email]>
wrote:

> Hello,
>     the attached minimal file fails to compile on VC++17/19 when using
> Boost 1.71.0b1.  It compiles successfully with Boost 1.70.0.  I also attach
> the compiler errors.
>
> Cheers,
>     Luigi
>
>
>

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost