All my Mac OS tests are failing

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

All my Mac OS tests are failing

Boost - Testing mailing list
On my Mac OS tester, all the tests are failing.

I run them like this:
    python run.py --runner=Marshall --toolsets=clang-03,clang-11,clang-14,clang-1z --bjam-options='-j 4' --tag=develop

My user-config.jam is attached.

all the tests fail with errors like:

     -x c++ -O0 -g -O0 -fno-inline -Wall -g -DBOOST_ALL_NO_LIB=1 -DBOOST_CHRONO_STATIC_LINK=1 -DBOOST_CHRONO_THREAD_DISABLED -DBOOST_SYSTEM_NO_DEPRECATED -DBOOST_SYSTEM_STATIC_LINK=1 -DBOOST_TEST_NO_AUTO_LINK=1 -DBOOST_TIMER_STATIC_LINK=1 -I".." -c -o "/Sources/boost/testing/results/boost/bin.v2/libs/accumulators/test/count.test/clang-gnu-darwin-03/debug/link-static/count.o" "../libs/accumulators/test/count.cpp"

/bin/sh: line 1: -x: command not found

It appears to be missing "/usr/bin/clang++"  - which is specified in my user-config.jam.


Interestingly enough, the web display seems to think that I'm running the toolset "clang-gnu-darwin-03"

Building individual libraries and/or running a single library's tests (via cd'ing to the test directory and running b2) seems to work fine.

    $BOOST/b2 --toolset=clang --toolset=clang-11 --toolset=clang-14 

Any ideas?

-- Marshall


_______________________________________________
Boost-Testing mailing list
[hidden email]
https://lists.boost.org/mailman/listinfo.cgi/boost-testing

user-config.jam (676 bytes) Download Attachment