Quantcast

[1.64][python] not building for Visual x64

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[1.64][python] not building for Visual x64

Boost - Dev mailing list
Hi,

I have some trouble building boost.python for the freshly released boost
1.64: there is no boost.python binary generated, and "bin.v2/libs" does
not contain any folder named "python".

Maybe related: the machine has python2.7 and 3.4 installed.

The command for building:

b2 toolset=msvc-14.0 --layout=versioned --build-type=complete
--without-log -j 4 address-model=64 threading=multi runtime-link=shared

The same command was used for 1.63 with no issue.

What am I missing? Let me know if this is a chair-to-keyboard problem.

Best,
Raffi

PS: logs of the second run attached (the number of messages for the
first run is flooding the console).


_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost

boost1.64-buildlogs.txt (56K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [1.64][python] not building for Visual x64

Boost - Dev mailing list
AMDG

On 04/26/2017 01:09 PM, Raffi Enficiaud via Boost wrote:

>
> I have some trouble building boost.python for the freshly released boost
> 1.64: there is no boost.python binary generated, and "bin.v2/libs" does
> not contain any folder named "python".
>
> Maybe related: the machine has python2.7 and 3.4 installed.
>
> The command for building:
>
> b2 toolset=msvc-14.0 --layout=versioned --build-type=complete
> --without-log -j 4 address-model=64 threading=multi runtime-link=shared
>
> The same command was used for 1.63 with no issue.
>
> What am I missing? Let me know if this is a chair-to-keyboard problem.
>

You're not the only one with this problem:
https://github.com/boostorg/build/issues/194
I haven't investigated the cause yet.

In Christ,
Steven Watanabe


_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [1.64][python] not building for Visual x64

Boost - Dev mailing list
Le 26/04/2017 à 21:25, Steven Watanabe via Boost a écrit :

> AMDG
>
> On 04/26/2017 01:09 PM, Raffi Enficiaud via Boost wrote:
>>
>> I have some trouble building boost.python for the freshly released boost
>> 1.64: there is no boost.python binary generated, and "bin.v2/libs" does
>> not contain any folder named "python".
>>
>> Maybe related: the machine has python2.7 and 3.4 installed.
>>
>> The command for building:
>>
>> b2 toolset=msvc-14.0 --layout=versioned --build-type=complete
>> --without-log -j 4 address-model=64 threading=multi runtime-link=shared
>>
>> The same command was used for 1.63 with no issue.
>>
>> What am I missing? Let me know if this is a chair-to-keyboard problem.
>>
>
> You're not the only one with this problem:
> https://github.com/boostorg/build/issues/194
> I haven't investigated the cause yet.

Good to know it is neither my chair nor my keyboard then :)

Thanks, following the ticket.
Raffi



_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Loading...